fsfe-website/shell.nix
Darragh Elliott 0b6ee1cc2f
All checks were successful
continuous-integration/drone/pr Build is passing
Add nix shell for developing
2024-09-02 12:49:39 +00:00

29 lines
505 B
Nix
Executable File

{
pkgs ? import <nixpkgs> {
config = { };
overlays = [ ];
},
}:
pkgs.mkShell {
nativeBuildInputs = with pkgs; [
# Needed for standard build
coreutils
findutils
gnused
gnugrep
gnumake
rsync
libxslt
libxml2
iconv
wget
# Needed for the site index script
python312
python312Packages.beautifulsoup4
# Needed only for non dev builds. IE --build-env "fsfe.org" or such
lessc
# Needed for translation status script
perl
];
}